Help! Water not coming out of RO unit - Wash It

I’ve had my WashIt since April '15 with little problems. Hooked it up this afternoon and no water coming out of the outlet from the RO filter. Water was coming out of the waste water at a typical flow.
Anyone have a clue what’s going on? I did a RO flush about a month ago.

captain obvious reporting!!! is it possible the valve at the ro outlet got turned off by accident??
also, could it be frozen??

lol. Yeah I worked my way backward because there was 0 water coming out of pole. 0 out of DI. 0 out of RO. You bet I worked that valve to be sure.

then waaaaah! guess it’s time to pull the valve and then the membrane :confounded:

Are you saying the membrane is shot?
I’m going to have to pop the lower valve off tonight.

If you have zero water coming out of the ball valve at the bottom of the stainless steel housing then something is blocking the water flow If it is coming out of the waste water then the water is getting through the housing but somehow the premade water is not being separated I would start by taking the ball valve off and make sure there is no blockage there If the ball valve is clear then remove the brass fitting to see if there is a blockage in it it is a 90° angle so there could be a blockage there


Thanks for the help John! I’ll check that out tonight.

no just that is something further in.

I took apart the elbow joint and blew into. Works fine. I was panicking tho we are right in the middle of busy fall season.

1 Like

Hey John. I took it apart last night. Blew through it and seemed to work fine. I hooked it up again this morning and still no water. Could that pressure piston-like piece be seizing up? What are those called maybe I can find one at a hardware store

Yes that is a one-way valve and it could be stuck I can order you a replacement or you can try to free it be very careful can you post a picture of it on here so I know were talking about the same part

That is called a check valve 1/2 npt

I have to order it.

That is covered by warranty can you call me or text me 8653100728

John. It’s not the elbow it’s the straight brass fitting attached to it.
I’m able to get some water flowing with really high psi. I use a Wayne 1/2 hp to boost pressure and on some jobs with really low output to start I won’t get anything. If I rattle the machine around and bang on it it seems to get some water flowing for a little bit and then it’ll slowly stop all together.
When I blow into the piece I’m able to blow air out at first but then it closes up even with blowing harder.

It’s just a real ball buster right in the middle of fall season send the part ASAP.

Hi please send John your # or give us a call. We would be happy to walk you through it and get it resolved.

Looks like we have this in the works for you already @John was able to get a replacement part from @Ipc_Eagle - Should be on its way to you soon.

Thx Chris and John.
Part is on it’s way per John Lee.

Hey John
Received the part real quick. Thanks
It’s not helping the problem tho. Water is still barely dribbling out of the pure water valve for RO. Water is still streaming fine out of the waste water valve.
Any other ideas for troubleshooting or should I call it a loss?

Do you have an iPhone - Maybe we can do a walkthrough with @John on Facetime. ? This has to be a simple fix, Id like to get it resolved ASAP for you.
If not Facetime maybe skype? Anything with video? So we can see what’s up with the unit.